Sets element

Specifies the minimum subset of the JavaScript API for Office that your Office Add-in requires in order to activate.

Add-in type: Content, Task pane, Mail

Syntax:

<Sets DefaultMinVersion="n .n ">
   ...
</Sets>

Contained in:

Requirements

Can contain:

Set

Attributes

Attribute Type Required Description
DefaultMinVersion string optional Specifies the default MinVersion attribute value for all child Set elements. The default value is "1.1".

Remarks

For more information about requirement sets, see Specify Office hosts and API requirements.

For more information about the MinVersion attribute of the Set element and the DefaultMinVersion attribute of the Sets element, see Set the Requirements element in the manifest.